Srsa 4c/Working with a broken camera

< User:Srsa 4c

588pages on
this wiki

If you plan to purchase a camera with the intention of using it without the lens, please ask before in this forum thread.

Operating the camera with faulty / missing lens or IS hardwareEdit

Missing or malfunctioning optical image stabilizerEdit

How to recognize?Edit

  • The camera stops with an E32 error, usually one minute after switching it on or switching it to rec mode.
  • The IS hardware is deliberately disconnected

Software solutionEdit

Cameras released in and after end of 2009 (DryOS r39 or later) have special event procedures dealing with IS errors in their firmware. They are called EnableISDriveError and (the one that's actually useful) DisableISDriveError. To use the latter, one could run a Lua script which invokes it correctly, or a modified CHDK could take care of the invocation.

To make sure your camera has these event procedures, please ask in this forum thread.

There are two kinds of cameras with IS

  • IS is disabled in play mode: DisableISDriveError needs to be invoked after each play -> rec mode transition
  • some parts of the IS unit are always in use, even in play mode: DisableISDriveError needs to be invoked after any play -> rec or rec -> play transition (* needs proof)

the following Lua script works on the S90 (to use it, use CHDK with native calls enabled, or CHDK 1.2)


Missing, broken or malfunctioning lens hardwareEdit

How to recognize?Edit

Partial software solutionEdit

This is of no use to most of the camera owners, except when the lens hardware is not needed (astronomical, microscopy applications)

Cameras released in 2011 or later have special event procedures named EnableLensError, DisableLensError. It is assumed that using DisableLensError could prevent camera shutdown in presence of certain (but not all!) lens related error conditions. For example, lens error still appears when the whole lens unit is disconnected, see these forum posts.


2011 and later entry level cameras have a dummy version of DisableLensError, which has no effect. These cameras seem to be the ones without optical IS hardware (A800, A810, A1200, A1300, A2200, A2300, ...?).

Possible hardware solutionEdit

Check out the following forum threads

Around Wikia's network

Random Wiki