Srsa 4c/Forgotten stuff

< User:Srsa 4c

587pages on
this wiki


Ixus220HS/Elph300HS, darkframe control which doesn't seem to work correctly for some reason

VxWorks cameras may need CAM_STARTUP_CRASH_FILE_OPEN_FIX too, like the A570IS

Cameras that may crash while recording a movie:

Mode switch issue found on some SX series cameras, and a possible remedy:

Obscure issue with scripted keypresses in the Canon menu on Digic 4 and higher (only reported on the S90, but probably affects more cameras). Might be related to the functions and fw variables used in vid_bitmap_refresh() implementations.

Might be worth it to review subject distance override restrictions on some cameras after changeset 2426, see also changeset 1453

Cameras where AF scan in video is problematic (not full list)

  • Ixus30/SD200, Ixus40/SD300: MakeAFScan() not found
  • A410 (@all res.)
reason (when 640x480 recording):
ASSERT!! WBInteg.c Line 869

Ixus95/SD1200, partition support may not work:

S90, looks like the ISO override fix in capt_seq.c is working, perhaps it should be added to the official source.

Various cameras have issues with open() or fopen() calls during video recording:

Edge overlay doesn't work well on cameras where the liveview buffers get overwritten during shooting:

CHDK crashes camera when it's started in "clock mode". All cameras seem to be affected:

SX510, using zebra (and/or histogram) sometimes results in memory corruption which leads to crash. The crash always seems to be connected to malloc(), memory used internally by malloc() is among the corrupted areas. Compiling with a different toolchain doesn't make a difference.

Filewritetask is causing trouble in a certain camera generation - supporting continuous mode seems pretty hard on them. - partially solved (CAM_FILEWRITETASK_MULTIPASS), although not for continuous mode

Remote shooting issues thread:

Certain SD cards appear to have CHDK compatibility problems on some cameras: SX160, SX130, SX150, A480

Severe DNG processing related problem on the sx170, there's also a similar report by an ixus125_elph110 user.

Further research or actual implementation needed:


A460, fast liveview buffer:

Possible explanation for the "ISO 100 gets recorded into DNG Exif" issue:

A470, on/off button as replacement for "disp" in ALT mode:

How to make CHDK's PTP implementation work on the first DIGIC II cameras

Possible workaround for the potential (data) cache vs. modules issue on the S1IS: cache control has been found, appears to work (or at least does not cause crashes).

Ixus105/SD1300, loading CHDK makes USB communication impossible (at least on 1.00d): , there's also a minor source fix pending

Ixus70/SD1000, saving DNG may fail (?), probably solved by this commit, see

A590IS, to not crash trying SD override

SX230HS, crashes while recording a movie when CHDK OSD is visible 101c 100c, weird tearing [1] Appears to be solved by

A4000, JPEGs tend to get corrupted when using the 'default' EXMEM configuration (aka. autobuild versions): and before... . According to rkomar's report, there's plenty of free RAM without using EXMEM. Hopefully solved by and

Around Wikia's network

Random Wiki