Wikia

CHDK Wiki

Talk:Getting CHDKPTP on BeagleBone Black to work

575pages on
this wiki

Back to page


No harm to add useful info for everyoneEdit

Please don't add sentences like "To learn more about how to use the cleint read: This page is not about learning to use CHDK"

There is a large number of amateurs and tinkerers come here and are really enthusiatic about CHDK. Over time, they tend to contribute a lot to the community.

So please try to give as much information as possible.

New users may find sentences like "his page is not about learning to use CHDK" offensive or the ones which deflect them from involving into this vast community.

Instead, add links, provide quick tips, or simply inform them to post in the forum. It's always a good idea to provide forum links.

Lua and LibUSB available for BeagleBone through OPKG Edit

LibUSB and Lua are currently available for download and install through the BeagleBone's built in package manager, opkg. This guide should be modified to use these sources for those libraries instead. This streamlines the process and avoids unnecessary steps in the guide. 


Proof:

root@beaglebone:~# opkg list | grep lua

lua5.1 - 5.1.4-r10.5 - lua5.1 version 5.1.4-r10

lua5.1-dev - 5.1.4-r10.5 - lua5.1 version 5.1.4-r10 - Development files

lua5.1-doc - 5.1.4-r10.5 - lua5.1 version 5.1.4-r10 - Documentation files

lua5.1-staticdev - 5.1.4-r10.5 - lua5.1 version 5.1.4-r10 - Development files (Static Libraries) root@beaglebone:~# opkg list | grep libusblibusb-0.1-4 - 1:0.1.3-r6.9 - libusb-compat version 0.1.3-r6 libusb-0.1 compatible layer for libusb1, a drop-in replacement that aimslibusb-0.1-dev - 1:0.1.3-r6.9 - libusb-compat version 0.1.3-r6 - Development files libusb-0.1 compatible layer for libusb1, a drop-in replacement that aimslibusb-0.1-staticdev - 1:0.1.3-r6.9 - libusb-compat version 0.1.3-r6 - Development files (Static Libraries) libusb-0.1 compatible layer for libusb1, a drop-in replacement that aimslibusb-1.0-0 - 1.0.9-r1.3 - libusb1 version 1.0.9-r1libusb-1.0-dev - 1.0.9-r1.3 - libusb1 version 1.0.9-r1 - Development fileslibusb-1.0-staticdev - 1.0.9-r1.3 - libusb1 version 1.0.9-r1 - Development files (Static Libraries) 

Around Wikia's network

Random Wiki